wiki:BS11/Troubleshooting

Troubleshooting

LMT

Known problems with the LMT connection

Problem: bs11_config can't get a connection to the BS-11 (no 'LMT LOGON: ACK')

Solution: The BS-11 is a little bit choosy about the RS232 levels, I discovered some problems with my Dell PC (could receive anything, but no tx). Just switch to an el-cheapo USB to Serial adapter, this should solve the problem.

Some background notes: We measured the RS232 levels and we found out that the level of our RS232<==>USB Adaptor is much lower (about +/-6 Volts) than normaly expected (+/-12V). The BS11 transmits at a semeliar level (about +/-8 Volts). This may be an explaination why the BS11 does not like the normal (+/-12V) levels.

From left to right: BTS-RX (PC-TX), BTS-TX (PC-RX), BTS-RX (PC-TX) with a real RS232 port.

There is no Firmware in the BTS

If you don't have the firmware in your BTS, you will need to download it, see bs11_config for instructions

The "everything looks good - nothing works" - problem

Early mISDN problems

When you use openBSC with early mISDN drivers (<= 2.6.31, patched) your setup might refuse to work while everything looks normal. No error messages, normal PLL Work Value Abis Link works perfect but no phone can see your network.

Than the first thing you should do is to upgrade your kernel to get the latest mISDN drivers.

Note: When your BS11 is out of Sync the setup also refuses to work. In this case you sould sync your BS11 as described in the isdnsync-howto.

See also: http://lists.gnumonks.org/pipermail/openbsc/2009-August/000783.html

Are your connectors working?

The Twinax-style connectors for E1 are prone to errors, as sometimes the pins are pushed into the plug while connecting the plug to the socket. If you're worried about this, simply use a ohm-meter and measure from the RJ45 side to the back-side of the connector board of the BTS.

Also, the polarity (which connector goes to Rx and Tx) could be incorrect, you can simply try that. From our experience it will not break anything.

Is the D-channel set correctly?

If you do not configure the E1 timeslot for the D channel correctly, i.e. to be the same on the BS-11 and on mISDN, nothing will work.

In our example configurations, the E1 timeslot is always set to 15. You can check the BTS side using bs11_config. You can check the mISDN side using the kernel log dmesg, it should indicate that a non-standard E1 timeslot 15 is used for the D-Channel.

E1 Card System does not recognize the E1 Card

Your E1 Card will not be recognized by the System. It does not appear in lspci, nor in the BIOS output when the system starts. In this case the problem is surely that your E1 card is configured to use the 3,3V PCI-Bus supply but your System has only a 5V PCI-Bus supply.

In this case the solution is to Change JP3 on the card so that the Card uses its internal 3,3V Voltage regulator. The image above shows a card that is configured to use the 3,3V from the PCI-BUS. It will not work in a pure 5V PCI-Slot.

The MS sees the network but can't login and there nothing visible on the console

We discovered that some SIM cards refuse the login into the network. In this case the MS does not even try to do a location update. You will get the "Not allowed" message immediately. That is also the reasoen why you do not see any requests on the openBSC console. You should try again with another SIM.

Last modified 3 years ago Last modified on Jul 13, 2011, 6:03:56 PM

Attachments (5)

Download all attachments as: .zip